UH Username - Solution to Error: "We are unable to find a good match for your information."

Problem

  • When completing the Check Status Form to create or reactivate your UH Username or reset your password, you are provided with the error "We are unable to find a good match for your information."

Resolution

  1. If you are using your full SSN for the ID Number, try to input your 8-digit UH ID number found on your campus ID card or acceptance letter
  2. Make sure the information you enter is inputted is correct and is what you submitted on your application or employment record (e.g. do not forget the hyphen if your last name has one)
  3. Check with your campus' records office or your personnel officer, to verify the record in UH's system(s) matches what you know
  4. If you are still encountering issues, contact the ITS Help Desk

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Cause

  • There is a discrepancy between the information you entered and the information within the UH Identity Management System
    • Students: This could have been due to a typo entered during the application process
    • Faculty/Staff: This could have been a typo you or your personnel officer made on your employment record

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